Corsi di programmazione web e mobile online
Risultati da 1 a 4 di 4

Discussione: aggiornamento app compatibile con iphone 6

  1. #1

    aggiornamento app compatibile con iphone 6

    Corso online di programmazione android e java
    Salve a tutti, ho necessità di aggiornare una mia app ma se provo ad avviarla dal simulatore iphone 6 mi compare il seguente errore:

    Codice:
    Solo gli utenti registrati possono visualizzare il codice. Only registered members can view code.
    la mia app utilizza la libreria Aviary. facendo una ricerca sul web sembra che sia la libreria il problema che non è compatibile con architettura a 64 bit ma purtroppo nelle impostazioni del progetto non trovo la voce per dis-abilitare l'architettura a 64 come consigliato in alcuni forum.

    possibile che sia dovuto al fatto che il progetto è stato startato con vecchia versione di xcode?

    Grazie a tutti
    Luca Santaniello
    skype: luca.santaniello

  2. #2
    Pardon, sono riusto ad aggiornare la configurazione seguendo questa procedura

    Product > Clean
    ALT + Product > Clean Build Folder

    Ho impostato a $(ARCHS_STANDARD_32_BIT) ma purtroppo l'errore persiste

    Codice:
    Solo gli utenti registrati possono visualizzare il codice. Only registered members can view code.
    consigli?
    Luca Santaniello
    skype: luca.santaniello

  3. #3
    Da febbraio per le nuove app e da giugno per gli update, tutte le applicazioni devono essere compatibili con l'architettura a 64 bit.
    https://developer.apple.com/news/?id=12172014b

    Se vuoi sfruttare i pochi mesi rimasti prova a dare un occhiata qua: http://stackoverflow.com/questions/2...e-in-xcode-5-1
    Ultima modifica di dymam; 15-04-15 alle 10:29

  4. #4
    Corso online di programmazione android e java
    Citazione Originariamente Scritto da luca.santaniello Visualizza Messaggio
    Pardon, sono riusto ad aggiornare la configurazione seguendo questa procedura

    Product > Clean
    ALT + Product > Clean Build Folder

    Ho impostato a $(ARCHS_STANDARD_32_BIT) ma purtroppo l'errore persiste

    Codice:
    Solo gli utenti registrati possono visualizzare il codice. Only registered members can view code.
    consigli?
    Quasi certamente la libreria è stata compilata per il device e non per il simulatore, per avere una libreria per entrambi bisogna fare due compilazioni della libreria statica con i due target e poi creare la cosiddetta FAT Library con il comando unix lipo -create qui su stackoverflow c'è una risposta:
    http://stackoverflow.com/questions/2...armv7-and-i386

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •